ManageEngine PAM360 REST API Restriction Bypass (CVE-2022-29081)

critical Nessus Plugin ID 161438

Synopsis

A privileged access management application is affected by a security bypass vulnerability.

Description

The ManageEngine PAM360 running on the remote host is affected by a security bypass vulnerability. An unauthenticated, remote attacker can exploit this, via specially crafted messages, to access certain REST API URLs that are not accessible otherwise.

Solution

Upgrade to PAM build 5401 or later.

See Also

http://www.nessus.org/u?cd7fa912

Plugin Details

Severity: Critical

ID: 161438

File Name: manageengine_pam360_cve-2022-29081.nbin

Version: 1.5

Type: remote

Family: CGI abuses

Published: 5/23/2022

Updated: 6/28/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2022-29081

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:zohocorp:manageengine_pam360

Required KB Items: installed_sw/ManageEngine PAM360

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 4/15/2022

Vulnerability Publication Date: 4/15/2022

Reference Information

CVE: CVE-2022-29081