Rocky Linux 8 : grub2 (RLSA-2022:2110)

low Nessus Plugin ID 161348

Synopsis

The remote Rocky Linux host is missing a security update.

Description

The remote Rocky Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RLSA-2022:2110 advisory.

- A flaw in grub2 was found where its configuration file, known as grub.cfg, is being created with the wrong permission set allowing non privileged users to read its content. This represents a low severity confidentiality issue, as those users can eventually read any encrypted passwords present in grub.cfg.
This flaw affects grub2 2.06 and previous versions. This issue has been fixed in grub upstream but no version with the fix is currently released. (CVE-2021-3981)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://errata.rockylinux.org/RLSA-2022:2110

https://bugzilla.redhat.com/show_bug.cgi?id=1809246

https://bugzilla.redhat.com/show_bug.cgi?id=1899903

https://bugzilla.redhat.com/show_bug.cgi?id=1914575

https://bugzilla.redhat.com/show_bug.cgi?id=2016269

https://bugzilla.redhat.com/show_bug.cgi?id=2020927

https://bugzilla.redhat.com/show_bug.cgi?id=2024170

https://bugzilla.redhat.com/show_bug.cgi?id=2048904

https://bugzilla.redhat.com/show_bug.cgi?id=2061252

https://bugzilla.redhat.com/show_bug.cgi?id=2069157

Plugin Details

Severity: Low

ID: 161348

File Name: rocky_linux_RLSA-2022-2110.nasl

Version: 1.2

Type: local

Published: 5/18/2022

Updated: 5/18/2022

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Low

Base Score: 2.1

Temporal Score: 1.6

Vector: AV:L/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-3981

CVSS v3

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.9

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:rocky:linux:grub2-common, p-cpe:/a:rocky:linux:grub2-debuginfo, p-cpe:/a:rocky:linux:grub2-debugsource, p-cpe:/a:rocky:linux:grub2-efi-aa64, p-cpe:/a:rocky:linux:grub2-efi-aa64-cdboot, p-cpe:/a:rocky:linux:grub2-efi-aa64-modules, p-cpe:/a:rocky:linux:grub2-efi-ia32, p-cpe:/a:rocky:linux:grub2-efi-ia32-cdboot, p-cpe:/a:rocky:linux:grub2-efi-ia32-modules, p-cpe:/a:rocky:linux:grub2-efi-x64, p-cpe:/a:rocky:linux:grub2-efi-x64-cdboot, p-cpe:/a:rocky:linux:grub2-efi-x64-modules, p-cpe:/a:rocky:linux:grub2-pc, p-cpe:/a:rocky:linux:grub2-pc-modules, p-cpe:/a:rocky:linux:grub2-tools, p-cpe:/a:rocky:linux:grub2-tools-debuginfo, p-cpe:/a:rocky:linux:grub2-tools-efi, p-cpe:/a:rocky:linux:grub2-tools-efi-debuginfo, p-cpe:/a:rocky:linux:grub2-tools-extra, p-cpe:/a:rocky:linux:grub2-tools-extra-debuginfo, p-cpe:/a:rocky:linux:grub2-tools-minimal, p-cpe:/a:rocky:linux:grub2-tools-minimal-debuginfo, cpe:/o:rocky:linux:8

Required KB Items: Host/local_checks_enabled, Host/RockyLinux/release, Host/RockyLinux/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/18/2022

Vulnerability Publication Date: 3/10/2022

Reference Information

CVE: CVE-2021-3981

RLSA: 2022:2110