GitLab 9.2 < 14.8.6 / 14.9.x < 14.9.4 / 14.10.x < 14.10.1 Incorrect Authorization

medium Nessus Plugin ID 161270


A source control application running on the remote web server is affected by an incorrect authorization vulnerability.


According to its self-reported version, the instance of GitLab running on the remote web server is 9.2 prior to 14.8.6, 14.9.x prior to 14.9.4, or 14.10.x prior to 14.10.1. It is, therefore, affected by the following vulnerability:

- A vulnerability exists in GitLab due to incorrect authorization on scheduled pipelines. An authenticated, remote attacker can exploit this, allowing a malicious user to run a pipeline in the context of another user. (CVE-2022-1460)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.8.6, 14.9.4, 14.10.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 161270

File Name: gitlab_cve-2022-1460.nasl

Version: 1.3

Type: combined

Family: CGI abuses

Published: 5/18/2022

Updated: 6/13/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2022-1460


Risk Factor: Medium

Base Score: 4.9

Temporal Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 5/2/2022

Vulnerability Publication Date: 5/2/2022

Reference Information

CVE: CVE-2022-1460

IAVA: 2022-A-0187-S