GitLab 12.6 < 14.8.6 / 14.9.x < 14.9.4 / 14.10.x < 14.10.1 Information Disclosure

low Nessus Plugin ID 161265

Synopsis

A source control application running on the remote web server is affected by an information disclosure vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is 12.6 prior to 14.8.6, 14.9.x prior to 14.9.4, or 14.10.x prior to 14.10.1. It is, therefore, affected by the following vulnerability:

- An information disclosure vulnerability exists in GitLab due to not correctly authenticating a user under certain circumstances. An authenticated, remote attacker can exploit this, to authenticate without using a personal access token. (CVE-2022-1426)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.8.6, 14.9.4, 14.10.1 or later.

See Also

http://www.nessus.org/u?c46a7cbd

Plugin Details

Severity: Low

ID: 161265

File Name: gitlab_cve-2022-1426.nasl

Version: 1.3

Type: combined

Family: CGI abuses

Published: 5/18/2022

Updated: 6/13/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-1426

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 5/2/2022

Vulnerability Publication Date: 5/2/2022

Reference Information

CVE: CVE-2022-1426

IAVA: 2022-A-0187-S