Ubuntu 14.04 LTS / 16.04 LTS / 20.04 LTS / 22.04 LTS : PCRE vulnerabilities (USN-5425-1)

high Nessus Plugin ID 161249

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 14.04 LTS / 16.04 LTS / 20.04 LTS / 22.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5425-1 advisory.

- libpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454. (CVE-2019-20838)

- libpcre in PCRE before 8.44 allows an integer overflow via a large number after a (?C substring.
(CVE-2020-14155)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5425-1

Plugin Details

Severity: High

ID: 161249

File Name: ubuntu_USN-5425-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/17/2022

Updated: 5/17/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-14155

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2019-20838

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:14.04:-:lts, cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libpcre16-3, p-cpe:/a:canonical:ubuntu_linux:libpcre3, p-cpe:/a:canonical:ubuntu_linux:libpcre3-dev, p-cpe:/a:canonical:ubuntu_linux:libpcre32-3, p-cpe:/a:canonical:ubuntu_linux:libpcrecpp0, p-cpe:/a:canonical:ubuntu_linux:libpcrecpp0v5, p-cpe:/a:canonical:ubuntu_linux:pcregrep

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/17/2022

Vulnerability Publication Date: 6/15/2020

Reference Information

CVE: CVE-2019-20838, CVE-2020-14155

USN: 5425-1