Debian DLA-3003-1 : ruby-nokogiri - LTS security update

high Nessus Plugin ID 161199

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has a package installed that is affected by a vulnerability as referenced in the dla-3003 advisory.

- Nokogiri is an open source XML and HTML library for Ruby. Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri `>= 1.13.4`. There are no known workarounds for this issue. (CVE-2022-24836)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the ruby-nokogiri packages.

For Debian 9 Stretch, these problems have been fixed in version 1.6.8.1-1+deb9u2.

See Also

https://www.debian.org/lts/security/2022/dla-3003

https://security-tracker.debian.org/tracker/CVE-2022-24836

https://packages.debian.org/source/stretch/ruby-nokogiri

Plugin Details

Severity: High

ID: 161199

File Name: debian_DLA-3003.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/14/2022

Updated: 5/14/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-24836

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby-nokogiri, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/13/2022

Vulnerability Publication Date: 4/11/2022

Reference Information

CVE: CVE-2022-24836