Adobe FrameMaker 2019 <= 15.0.8 (2019.0.8) / Adobe FrameMaker 2020 <= 16.0.4 (2020.0.4) Multiple Vulnerabilities (APSB22-27)

high Nessus Plugin ID 161175

Synopsis

The remote install of Adobe FrameMaker has multiple vulnerabilities.

Description

The version of Adobe FrameMaker installed on the remote Windows host is 2019 release prior or equal to 15.0.8, or 2020 release 16.0.4. It is, therefore, potentially affected by multiple arbitrary code execution vulnerabilities due to out-of-bounds writes as well as a memory leak vulnerability due to an out-of-bounds-read, as referenced in the APSB22-27 advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe FrameMaker version 15.0.9, 16.0.5 or later.

See Also

https://helpx.adobe.com/security/products/framemaker/apsb22-27.html

Plugin Details

Severity: High

ID: 161175

File Name: adobe_framemaker_apsb22-27.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 5/13/2022

Updated: 5/24/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2022-28829

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:framemaker

Required KB Items: installed_sw/Adobe FrameMaker, SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 5/10/2022

Vulnerability Publication Date: 5/10/2022

Reference Information

CVE: CVE-2022-28821, CVE-2022-28822, CVE-2022-28823, CVE-2022-28824, CVE-2022-28825, CVE-2022-28826, CVE-2022-28827, CVE-2022-28828, CVE-2022-28829, CVE-2022-28830

IAVB: 2022-B-0013

CWE: 125, 416, 787