Adobe InDesign < 16.4.2 / < 17.2 Multiple Vulnerabilities (APSB22-23)

high Nessus Plugin ID 161174

Synopsis

The remote host has an application installed that is affected by multiple vulnerabilities.

Description

The version of Adobe InDesign installed on the remote host is prior to 16.4.2 and or 17.x prior to 17.2. It is, therefore, affected by multiple vulnerabilities, as follows:

- The vulnerability exists due to a boundary error when processing embedded fonts. A remote attacker can create a specially crafted file, trick the victim into opening it using the affected software, trigger out-of-bounds write and execute arbitrary code on the target system. (CVE-2022-28831)

- The vulnerability allows a remote attacker to compromise vulnerable system. The vulnerability exists due to a boundary error when processing embedded fonts. A remote attacker can create a specially crafted file, trick the victim into opening it using the affected software, trigger out-of-bounds read and execute arbitrary code on the target system. (CVE-2022-28832, CVE-2022-28833)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe InDesign version 16.4.2, 17.2 or later.

See Also

https://helpx.adobe.com/security/products/indesign/apsb22-23.html

Plugin Details

Severity: High

ID: 161174

File Name: adobe_indesign_apsb22-23.nasl

Version: 1.2

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 5/13/2022

Updated: 5/18/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2022-28831

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:indesign

Required KB Items: installed_sw/Adobe InDesign

Exploit Ease: No known exploits are available

Patch Publication Date: 5/10/2022

Vulnerability Publication Date: 5/10/2022

Reference Information

CVE: CVE-2022-28831, CVE-2022-28832, CVE-2022-28833

IAVA: 2022-A-0205