Security Updates for Microsoft .NET core (May 2022)

high Nessus Plugin ID 161167

Synopsis

The Microsoft .NET core installations on the remote host are affected by multiple vulnerabilities.

Description

The Microsoft .NET core installations on the remote host are missing security updates. It is, therefore, affected by multiple denial of service vulnerabilities:

- A vulnerability where a malicious client can cause a denial of service via excess memory allocations through HttpClient. (CVE-2022-23267)

- A vulnerability where a malicious client can manipulate cookies and cause a denial of service. (CVE-2022-29117)

- A vulnerability where a malicious client can cause a denial of service when HTML forms are parsed. (CVE-2022-29145)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update .NET Core Runtime to version 3.1.25, 5.0.17 or 6.0.5.

See Also

https://dotnet.microsoft.com/download/dotnet/3.1

https://dotnet.microsoft.com/download/dotnet/5.0

https://dotnet.microsoft.com/download/dotnet/6.0

https://github.com/dotnet/announcements/issues/219

http://www.nessus.org/u?3b99f604

http://www.nessus.org/u?b1b0aff4

http://www.nessus.org/u?39d07c32

Plugin Details

Severity: High

ID: 161167

File Name: smb_nt_ms22_may_dotnet_core.nasl

Version: 1.6

Type: local

Family: Misc.

Published: 5/13/2022

Updated: 5/18/2022

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure

Risk Information

CVSS Score Source: CVE-2022-23267

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:.net_core

Exploit Ease: No known exploits are available

Patch Publication Date: 5/10/2022

Vulnerability Publication Date: 5/10/2022

Reference Information

CVE: CVE-2022-23267, CVE-2022-29117, CVE-2022-29145

IAVA: 2022-A-0201