CentOS 8 : rust-toolset:rhel8 (CESA-2022:1894)

medium Nessus Plugin ID 160912

Synopsis

The remote CentOS host is missing a security update.

Description

The remote CentOS Linux 8 host has packages installed that are affected by a vulnerability as referenced in the CESA-2022:1894 advisory.

- rust: Race condition in remove_dir_all leading to removal of files outside of the directory being removed (CVE-2022-21658)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://access.redhat.com/errata/RHSA-2022:1894

Plugin Details

Severity: Medium

ID: 160912

File Name: centos8_RHSA-2022-1894.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/10/2022

Updated: 5/10/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

Risk Information

VPR

Risk Factor: Medium

Score: 6

CVSS v2

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.4

Vector: AV:L/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-21658

CVSS v3

Risk Factor: Medium

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:cargo, p-cpe:/a:centos:centos:cargo-doc, p-cpe:/a:centos:centos:clippy, p-cpe:/a:centos:centos:rls, p-cpe:/a:centos:centos:rust, p-cpe:/a:centos:centos:rust-analysis, p-cpe:/a:centos:centos:rust-debugger-common, p-cpe:/a:centos:centos:rust-doc, p-cpe:/a:centos:centos:rust-gdb, p-cpe:/a:centos:centos:rust-lldb, p-cpe:/a:centos:centos:rust-src, p-cpe:/a:centos:centos:rust-std-static, p-cpe:/a:centos:centos:rust-std-static-wasm32-unknown-unknown, p-cpe:/a:centos:centos:rust-std-static-wasm32-wasi, p-cpe:/a:centos:centos:rust-toolset, p-cpe:/a:centos:centos:rustfmt

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/10/2022

Vulnerability Publication Date: 1/20/2022

Reference Information

CVE: CVE-2022-21658

RHSA: 2022:1894