Tenable SecurityCenter 5.12.x - 5.18.x / 5.19.x / 5.20.x Multiple Vulnerabilities (TNS-2022-08)

critical Nessus Plugin ID 160884


An application installed on the remote host is affected by multiple vulnerabilities.


According to its self-reported version, the Tenable SecurityCenter application installed on the remote host is running 5.19.x or 5.20.x and is therefore affected by multiple vulnerabilities:

- Read/write beyond bounds - Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions. (CVE-2022-23943)
- A denial of service (DoS) vulnerability exists in OpenSSL due to an infinite loop bug in the BN_mod_sqrt() function. An unauthenticated, remote attacker can exploit this issue, via self-signed certificate, to trigger the loop during verification of the the certificate signature. (CVE-2022-0778) Note that successful exploitation of the most serious issues can result in arbitrary code execution.


Apply the security patch referenced in the vendor advisory or upgrade to 5.21.0 or later.

See Also




Plugin Details

Severity: Critical

ID: 160884

File Name: securitycenter_5_21_0_tns_2022_04_1.nasl

Version: 1.3

Type: local

Agent: unix

Family: Misc.

Published: 5/10/2022

Updated: 6/3/2022

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: High

Score: 7.4


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2022-23943


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/6/2022

Vulnerability Publication Date: 4/6/2022

Reference Information

CVE: CVE-2022-0778, CVE-2022-23943