Debian DSA-5132-1 : ecdsautils - security update

high Nessus Plugin ID 160846

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 / 11 host has a package installed that is affected by a vulnerability as referenced in the dsa-5132 advisory.

- ecdsautils is a tiny collection of programs used for ECDSA (keygen, sign, verify).
`ecdsa_verify_[prepare_]legacy()` does not check whether the signature values `r` and `s` are non-zero. A signature consisting only of zeroes is always considered valid, making it trivial to forge signatures.
Requiring multiple signatures from different public keys does not mitigate the issue:
`ecdsa_verify_list_legacy()` will accept an arbitrary number of such forged signatures. Both the `ecdsautil verify` CLI command and the libecdsautil library are affected. The issue has been fixed in ecdsautils 0.4.1. All older versions of ecdsautils (including versions before the split into a library and a CLI utility) are vulnerable. (CVE-2022-24884)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the ecdsautils packages.

For the stable distribution (bullseye), this problem has been fixed in version 0.3.2+git20151018-2+deb11u1.

See Also

https://security-tracker.debian.org/tracker/source-package/ecdsautils

https://www.debian.org/security/2022/dsa-5132

https://security-tracker.debian.org/tracker/CVE-2022-24884

https://packages.debian.org/source/buster/ecdsautils

https://packages.debian.org/source/bullseye/ecdsautils

Plugin Details

Severity: High

ID: 160846

File Name: debian_DSA-5132.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/10/2022

Updated: 5/10/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-24884

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ecdsautils, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 5/6/2022

Reference Information

CVE: CVE-2022-24884