GitLab < 14.8.6 / 14.9.x < 14.9.4 / 14.10.x < 14.10.1 Multiple Vulnerabilities

medium Nessus Plugin ID 160670


A source control application running on the remote web server is affected by multiple vulnerabilities.


According to its self-reported version, the instance of GitLab running on the remote web server is prior to 14.8.6, 14.9.x prior to 14.9.4, or 14.10.x prior to 14.10.1. It is, therefore, affected by the following vulnerabilities:

- An improper authorization issue exists in GitLab CE/EE that allows an authenticated, remote attacker to access trace log of jobs as Guest project members when it is enabled. (CVE-2022-1124)

- An issue exists in GitLab due to incorrectly verifying throttling limits for authenticated package requests that allows an authenticated, remote attacker to cause bypass throttling limits. (CVE-2022-1428)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.8.6, 14.9.4, 14.10.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 160670

File Name: gitlab_14_10_1.nasl

Version: 1.4

Type: combined

Family: CGI abuses

Published: 5/6/2022

Updated: 6/13/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Low

Score: 1.4


Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:N/A:N

CVSS Score Source: CVE-2022-1124


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 5/2/2022

Vulnerability Publication Date: 5/2/2022

Reference Information

CVE: CVE-2022-1124, CVE-2022-1428

IAVA: 2022-A-0187-S