GLSA-200412-24 : Xpdf, GPdf: New integer overflows

High Nessus Plugin ID 16066


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200412-24 (Xpdf, GPdf: New integer overflows)

A new integer overflow issue was discovered in Xpdf's Gfx::doImage() function.
Impact :

An attacker could entice an user to open a specially crafted PDF file, potentially resulting in execution of arbitrary code with the rights of the user running Xpdf or GPdf.
Workaround :

There is no known workaround at this time.


All Xpdf users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/xpdf-3.00-r7' All GPdf users should also upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/gpdf-2.8.1-r1'

See Also

Plugin Details

Severity: High

ID: 16066

File Name: gentoo_GLSA-200412-24.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2004/12/28

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gpdf, p-cpe:/a:gentoo:linux:xpdf, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/12/28

Vulnerability Publication Date: 2004/12/21

Reference Information

CVE: CVE-2004-1125

OSVDB: 12554

GLSA: 200412-24

CWE: 20