Fedora Core 2 : cups-1.1.20-11.8 (2004-574)

High Nessus Plugin ID 16055


The remote Fedora Core host is missing a security update.


This package fixes a buffer overflow which may possibly allow attackers to execute arbitrary code as the 'lp' user. The Common Vulnerabilities and Exposures projects (cve.mitre.org) has assigned the name CVE-2004-1125 to this issue.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

See Also


Plugin Details

Severity: High

ID: 16055

File Name: fedora_2004-574.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2004/12/27

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:cups, p-cpe:/a:fedoraproject:fedora:cups-debuginfo, p-cpe:/a:fedoraproject:fedora:cups-devel, p-cpe:/a:fedoraproject:fedora:cups-libs, cpe:/o:fedoraproject:fedora_core:2

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2004/12/22

Reference Information

CVE: CVE-2004-1125

FEDORA: 2004-574

CWE: 20