Debian DLA-2990-1 : jackson-databind - LTS security update

high Nessus Plugin ID 160453

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has packages installed that are affected by a vulnerability as referenced in the dla-2990 advisory.

- jackson-databind before 2.13.0 allows a Java StackOverflow exception and denial of service via a large depth of nested objects. (CVE-2020-36518)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the jackson-databind packages.

For Debian 9 stretch, this problem has been fixed in version 2.8.6-1+deb9u10.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1007109

http://www.nessus.org/u?61134ddf

https://www.debian.org/lts/security/2022/dla-2990

https://security-tracker.debian.org/tracker/CVE-2020-36518

https://packages.debian.org/source/stretch/jackson-databind

Plugin Details

Severity: High

ID: 160453

File Name: debian_DLA-2990.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/2/2022

Updated: 5/2/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-36518

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libjackson2-databind-java, p-cpe:/a:debian:debian_linux:libjackson2-databind-java-doc, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/2/2022

Vulnerability Publication Date: 3/11/2022

Reference Information

CVE: CVE-2020-36518