Debian DLA-2989-1 : ghostscript - LTS security update

high Nessus Plugin ID 160398

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-2989 advisory.

- Artifex Ghostscript through 9.26 mishandles .completefont. NOTE: this issue exists because of an incomplete fix for CVE-2019-3839. (CVE-2019-25059)

- It was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable. (CVE-2019-3839)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the ghostscript packages.

For Debian 9 stretch, this problem has been fixed in version 9.26a~dfsg-0+deb9u9.

See Also

https://security-tracker.debian.org/tracker/source-package/ghostscript

https://www.debian.org/lts/security/2022/dla-2989

https://security-tracker.debian.org/tracker/CVE-2019-25059

https://security-tracker.debian.org/tracker/CVE-2019-3839

https://packages.debian.org/source/stretch/ghostscript

Plugin Details

Severity: High

ID: 160398

File Name: debian_DLA-2989.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/2/2022

Updated: 5/2/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2019-3839

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ghostscript, p-cpe:/a:debian:debian_linux:ghostscript-dbg, p-cpe:/a:debian:debian_linux:ghostscript-doc, p-cpe:/a:debian:debian_linux:ghostscript-x, p-cpe:/a:debian:debian_linux:libgs-dev, p-cpe:/a:debian:debian_linux:libgs9, p-cpe:/a:debian:debian_linux:libgs9-common, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/1/2022

Vulnerability Publication Date: 5/2/2019

Reference Information

CVE: CVE-2019-3839, CVE-2019-25059

IAVB: 2019-B-0042-S