GLSA-200412-18 : abcm2ps: Buffer overflow vulnerability

Medium Nessus Plugin ID 16005


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200412-18 (abcm2ps: Buffer overflow vulnerability)

Limin Wang has located a buffer overflow inside the put_words() function in the abcm2ps code.
Impact :

A remote attacker could convince the victim to download a specially crafted ABC file. Upon execution, this file would trigger the buffer overflow and lead to the execution of arbitrary code with the permissions of the user running abcm2ps.
Workaround :

There is no known workaround at this time.


All abcm2ps users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-sound/abcm2ps-3.7.21'

See Also

Plugin Details

Severity: Medium

ID: 16005

File Name: gentoo_GLSA-200412-18.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/12/20

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:abcm2ps, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/12/19

Vulnerability Publication Date: 2004/12/17

Reference Information

OSVDB: 12431

GLSA: 200412-18