GLSA-200412-17 : kfax: Multiple overflows in the included TIFF library

high Nessus Plugin ID 16004

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200412-17 (kfax: Multiple overflows in the included TIFF library)

Than Ngo discovered that kfax contains a private copy of the TIFF library and is therefore subject to several known vulnerabilities (see References).
Impact :

A remote attacker could entice a user to view a carefully-crafted TIFF image file with kfax, which would potentially lead to execution of arbitrary code with the rights of the user running kfax.
Workaround :

The KDE Team recommends to remove the kfax binary as well as the kfaxpart.la KPart:
rm /usr/kde/3.*/lib/kde3/kfaxpart.la rm /usr/kde/3.*/bin/kfax Note: This will render the kfax functionality useless, if kfax functionality is needed you should upgrade to the KDE 3.3.2 which is not stable at the time of this writing.
There is no known workaround at this time.

Solution

All kfax users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=kde-base/kdegraphics-3.3.2'

See Also

https://www.kde.org/info/security/advisory-20041209-2.txt

https://security.gentoo.org/glsa/200410-11

https://security.gentoo.org/glsa/200412-17

Plugin Details

Severity: High

ID: 16004

File Name: gentoo_GLSA-200412-17.nasl

Version: 1.21

Type: local

Published: 12/20/2004

Updated: 1/6/2021

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:kdegraphics, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 12/19/2004

Reference Information

CVE: CVE-2004-0803, CVE-2004-0804, CVE-2004-0886

GLSA: 200412-17