GitLab 12.0 < 14.3.6 / 14.4.0 < 14.4.4 / 14.5.0 < 14.5.2 DoS

medium Nessus Plugin ID 159958


A source control application running on the remote web server is affected by a denial of service vulnerability.


According to its self-reported version, the instance of GitLab running on the remote web server is 12.0 prior to 14.3.6, 14.4.0 prior to 14.4.4, or 14.5.0 prior to 14.5.2. It is, therefore, vulnerable to a denial of service vulnerability where low-privileged users could bypass file size limits in the NPM package repository to cause a denial of service.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.3.6 / 14.4.4 / 14.5.2 or later.

See Also

Plugin Details

Severity: Medium

ID: 159958

File Name: gitlab_cve-2021-39942.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 4/20/2022

Updated: 4/7/2023

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

CVSS Score Source: CVE-2021-39942


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2021

Vulnerability Publication Date: 1/18/2021

Reference Information

CVE: CVE-2021-39942

IAVA: 2022-A-0021-S