GitLab 14.3 < 14.3.6 / 14.4 < 14.4.3 / 14.5 < 14.5.2 XSS

medium Nessus Plugin ID 159957

Synopsis

A source control application running on the remote web server is affected by an XSS vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is 14.3 prior to 14.3.6, 14.4 prior to 14.4.4, or 14.5 prior to 14.5.2. It is, therefore, vulnerable to XSS due to improper neutralization of user input and can allow an attacker to exploit XSS by abusing the generation of the HTML related code related to emojis.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.3.6 / 14.4.3 / 14.5.2 or later.

See Also

http://www.nessus.org/u?9af276e8

Plugin Details

Severity: Medium

ID: 159957

File Name: gitlab_cve-2021-39946.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 4/20/2022

Updated: 7/26/2022

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-39946

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2021

Vulnerability Publication Date: 1/18/2021

Reference Information

CVE: CVE-2021-39946

IAVA: 2022-A-0021-S