GitLab 12.0 < 14.4.5 / 14.5.0 < 14.5.3 / 14.6.0 < 14.6.2 Improper Access

medium Nessus Plugin ID 159956

Synopsis

A source control application running on the remote web server is affected by an improper access vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is 12.0 prior to 14.4.5, 14.5.0 prior to 14.5.3, or 14.6.0 prior to 14.6.2. It is, therefore, vulnerable to an access permissions vulnerability where GitLab was not verifying that a maintainer of a porject had the right access to import members from a target project.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.4.5 / 14.5.3 / 14.6.2 or later.

See Also

http://www.nessus.org/u?d83ed963

Plugin Details

Severity: Medium

ID: 159956

File Name: gitlab_cve-2022-0125.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 4/20/2022

Updated: 7/26/2022

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-0125

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2021

Vulnerability Publication Date: 1/18/2021

Reference Information

CVE: CVE-2022-0125

IAVA: 2022-A-0021-S