GitLab 13.7.0 < 14.2.6 / 14.3.0 < 14.3.4 / 14.4.0 < 14.4.1 Denial Of Service

medium Nessus Plugin ID 159928


A source control application running on the remote web server is affected by adenial of service vulnerability.


According to its self-reported version, the instance of GitLab running on the remote web server is 13.7.0 prior to 14.2.6, 14.3.0 prior to 14.3.4, or 14.4.0 prior to 14.4.1. It is, therefore, affected by an denial of service vulnerability due to the stripping of EXIF data from certain images resulting in high CPU usage.
An unauthenticated, remote attacker could exploit this vulnerability to lead to a denial of service.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.2.6, 14.3.4, 14.4.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 159928

File Name: gitlab_cve-2021-39907.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 4/20/2022

Updated: 7/26/2022

Risk Information


Risk Factor: Low

Score: 1.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-39907


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 4/11/2021

Vulnerability Publication Date: 4/11/2021

Reference Information

CVE: CVE-2021-39907

IAVA: 2021-A-0523-S