GitLab 12.10.0 < 14.2.6 / 13.0.0 < 14.3.4 / 13.1.0 < 14.4.1 Improper Access Control

medium Nessus Plugin ID 159920


A source control application running on the remote web server is affected by an improper access control vulnerability.


According to its self-reported version, the instance of GitLab running on the remote web server is 12.10.0 prior to 14.2.6, 13.0.0 prior to 14.3.4, or 13.1.0 prior to 14.4.1. It is, therefore, affected by an improper access control vulnerability due to pipelines activated by default on imported projects. An unauthenticated, remote attacker could exploit this vulnerability to lead to information disclosure.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.2.6, 14.3.4, 14.4.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 159920

File Name: gitlab_cve-2021-39904.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 4/20/2022

Updated: 7/26/2022

Risk Information


Risk Factor: Low

Score: 2.2


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-39904


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 4/11/2021

Vulnerability Publication Date: 4/11/2021

Reference Information

CVE: CVE-2021-39904

IAVA: 2021-A-0523-S