GitLab 14.4.x < 14.7.7 / 14.8.x < 14.8.5 / 14.9.x < 14.8.2 XSS

medium Nessus Plugin ID 159823

Synopsis

A source control application running on the remote web server is affected by a cross-site scripting vulnerability.

Description

Improper neutralization of user input in GitLab CE/EE versions 14.4 before 14.7.7, all versions starting from 14.8 before 14.8.5, all versions starting from 14.9 before 14.9.2 allowed an attacker to exploit XSS by injecting HTML in notes.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.7.7, 14.8.5, 14.9.2, or later.

See Also

http://www.nessus.org/u?eea093a9

Plugin Details

Severity: Medium

ID: 159823

File Name: gitlab_cve-2022-1175.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 4/18/2022

Updated: 7/26/2022

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2022-1175

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/31/2022

Vulnerability Publication Date: 3/31/2022

Reference Information

CVE: CVE-2022-1175

IAVA: 2022-A-0131-S