GitLab 13.11.x < 14.7.7 / 14.8.x < 14.8.5 / 14.9.x < 14.8.2 Improper Access Control

medium Nessus Plugin ID 159819

Synopsis

A source control application running on the remote web server is affected by an improper access control vulnerability.

Description

An improper access control vulnerability in GitLab CE/EE affecting all versions from 13.11 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allows an unauthorized user to access pipeline analytics even when public pipelines are disabled.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.7.7, 14.8.5, 14.9.2, or later.

See Also

http://www.nessus.org/u?eea093a9

Plugin Details

Severity: Medium

ID: 159819

File Name: gitlab_cve-2022-1105.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 4/18/2022

Updated: 7/26/2022

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-1105

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 3/31/2022

Vulnerability Publication Date: 3/31/2022

Reference Information

CVE: CVE-2022-1105

IAVA: 2022-A-0131-S