GitLab < 14.7.7 / 14.8.x < 14.8.5 / 14.9.x < 14.9.2 Multiple Vulnerabilities

medium Nessus Plugin ID 159818

Synopsis

A source control application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is prior to 14.7.7 14.8.x prior to 14.8.5, or 14.9.x prior to 14.9.2. It is, therefore, affected by the following vulnerabilities:

- Adding a very large number of tags to a runner in GitLab CE/EE allows an attacker to impact the performance of GitLab. (CVE-2022-1099)

- Missing filtering in an error message in GitLab CE/EE exposes sensitive information when an include directive fails in the CI/CD configuration. (CVE-2022-1120)

- A lack of appropriate timeouts in GitLab Pages included in GitLab CE/EE allows an attacker to cause unlimited resource consumption. (CVE-2022-1121)

- Missing sanitization of logged exception messages causes potential sensitive values in invalid URLs to be logged.
(CVE-2022-1157)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.7.7, 14.8.5, 14.9.2 or later.

See Also

http://www.nessus.org/u?35c16f9f

http://www.nessus.org/u?b85d5630

Plugin Details

Severity: Medium

ID: 159818

File Name: gitlab_14_9_2.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 4/18/2022

Updated: 7/26/2022

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-1120

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 3/31/2022

Vulnerability Publication Date: 3/31/2022

Reference Information

CVE: CVE-2022-1099, CVE-2022-1120, CVE-2022-1121, CVE-2022-1157

IAVA: 2022-A-0131-S