Palo Alto Networks PAN-OS 8.1.x < 8.1.22 / 9.0.x < 9.0.16 / 9.1.x < 9.1.13 / 10.0.x < 10.0.10 / 10.1.x < 10.1.5 Vulnerability

medium Nessus Plugin ID 159713

Synopsis

The remote PAN-OS host is affected by a vulnerability

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 8.1.x prior to 8.1.22 or 9.0.x prior to 9.0.16 or 9.1.x prior to 9.1.13 or 10.0.x prior to 10.0.10 or 10.1.x prior to 10.1.5. It is, therefore, affected by a vulnerability.

- An improper handling of exceptional conditions vulnerability exists in the DNS proxy feature of Palo Alto Networks PAN-OS software that enables a meddler-in-the-middle (MITM) to send specifically crafted traffic to the firewall that causes the service to restart unexpectedly. Repeated attempts to send this request result in denial-of-service to all PAN-OS services by restarting the device in maintenance mode.
(CVE-2022-0023)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 8.1.22 / 9.0.16 / 9.1.13 / 10.0.10 / 10.1.5 or later

See Also

https://security.paloaltonetworks.com/CVE-2022-0023

https://cwe.mitre.org/data/definitions/755.html

Plugin Details

Severity: Medium

ID: 159713

File Name: palo_alto_CVE-2022-0023.nasl

Version: 1.3

Type: combined

Published: 4/13/2022

Updated: 4/26/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-0023

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/13/2022

Vulnerability Publication Date: 4/13/2022

Reference Information

CVE: CVE-2022-0023

CWE: 755