Debian DLA-2980-1 : zabbix - LTS security update

medium Nessus Plugin ID 159663

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-2980 advisory.

- An authenticated user can create a link with reflected XSS payload for actions' pages, and send it to other users. Malicious code has access to all the same objects as the rest of the web page and can make arbitrary modifications to the contents of the page being displayed to a victim. This attack can be implemented with the help of social engineering and expiration of a number of factors - an attacker should have authorized access to the Zabbix Frontend and allowed network connection between a malicious server and victim's computer, understand attacked infrastructure, be recognized by the victim as a trustee and use trusted communication channel. (CVE-2022-24349)

- An authenticated user can create a link with reflected Javascript code inside it for services' page and send it to other users. The payload can be executed only with a known CSRF token value of the victim, which is changed periodically and is difficult to predict. Malicious code has access to all the same objects as the rest of the web page and can make arbitrary modifications to the contents of the page being displayed to a victim during social engineering attacks. (CVE-2022-24917)

- An authenticated user can create a link with reflected Javascript code inside it for graphs' page and send it to other users. The payload can be executed only with a known CSRF token value of the victim, which is changed periodically and is difficult to predict. Malicious code has access to all the same objects as the rest of the web page and can make arbitrary modifications to the contents of the page being displayed to a victim during social engineering attacks. (CVE-2022-24919)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the zabbix packages.

For Debian 9 stretch, these problems have been fixed in version 1

See Also

https://packages.debian.org/source/stretch/zabbix

https://security-tracker.debian.org/tracker/source-package/zabbix

https://www.debian.org/lts/security/2022/dla-2980

https://security-tracker.debian.org/tracker/CVE-2022-24349

https://security-tracker.debian.org/tracker/CVE-2022-24917

https://security-tracker.debian.org/tracker/CVE-2022-24919

Plugin Details

Severity: Medium

ID: 159663

File Name: debian_DLA-2980.nasl

Version: 1.2

Type: local

Agent: unix

Published: 4/12/2022

Updated: 4/12/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Low

Base Score: 2.1

Temporal Score: 1.6

Vector: CVSS2#AV:N/AC:H/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-24919

CVSS v3

Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.9

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-agent:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-frontend-php:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-java-gateway:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-proxy-mysql:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-proxy-pgsql:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-proxy-sqlite3:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-server-mysql:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:zabbix-server-pgsql:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 4/12/2022

Vulnerability Publication Date: 3/9/2022

Reference Information

CVE: CVE-2022-24349, CVE-2022-24917, CVE-2022-24919