Winamp < 5.0.7 Multiple File Handling DoS

Low Nessus Plugin ID 15952


The remote host is vulnerable to denial of service attacks.


The remote host is using Winamp, a popular media player that handles many file formats (mp3, wavs and more...)

The remote version of this software is vulnerable to denial of service attacks when it processes malformed .mp4 / .m4a or .nsv / .nsa files.

An attacker may exploit this flaw by sending malformed files to a victim on the remote host.


Upgrade to Winamp version 5.0.7 or later.

See Also

Plugin Details

Severity: Low

ID: 15952

File Name: winamp_mp4_dos.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2004/12/14

Modified: 2016/11/29

Dependencies: 15817

Risk Information

Risk Factor: Low


Base Score: 2.6

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2004/12/14

Reference Information

CVE: CVE-2004-1396

BID: 11909

OSVDB: 12490, 12491