Apache Tomcat 9.0.0.M1 < 9.0.62 Spring4Shell (CVE-2022-22965) Mitigations

low Nessus Plugin ID 159464

Synopsis

The remote Apache Tomcat server is affected by a vulnerability

Description

The version of Apache Tomcat installed on the remote host is 9.x prior to 9.0.62.

This version of Apache Tomcat does not have mitigations in place to protect against Spring4Shell (CVE-2022-22965). While this does not represent a vulnerability in Apache Tomcat itself, it is recommend to update Apache Tomcat to a version with the Spring4Shell mitigations present.

Note that Nessus has not tested for the mitigations but has instead relied only on the application's self-reported version number.);
# https://spring.io/blog/2022/04/01/spring-framework-rce-mitigation-alternative script_set_attribute(attribute:see_also, value:http://www.nessus.org/u?2401ae46

Solution

Upgrade to Apache Tomcat version 9.0.62 or later.

See Also

http://www.nessus.org/u?f8a02181

http://www.nessus.org/u?a9b73a07

Plugin Details

Severity: Low

ID: 159464

File Name: tomcat_9_0_62.nasl

Version: 1.3

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 4/1/2022

Updated: 1/4/2023

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Low

Base Score: 2.6

Temporal Score: 1.9

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-43980

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Required KB Items: installed_sw/Apache Tomcat

Exploit Ease: No known exploits are available

Patch Publication Date: 4/1/2022

Vulnerability Publication Date: 4/1/2022

Reference Information

CVE: CVE-2021-43980