Amazon Corretto Java 8.x < 8.232.09.1 Multiple Vulnerabilities

medium Nessus Plugin ID 159430

Synopsis

Amazon Corretto is affected by multiple vulnerabilities.

Description

The version of Amazon Corretto installed on the remote host is prior to 8 < 8.232.09.1. It is, therefore, affected by multiple vulnerabilities as referenced in the corretto-8-2019-Oct-15 advisory.

- security-libs/javax.net.ssl (CVE-2019-2894, CVE-2019-2949)

- core-libs (CVE-2019-2933)

- core-libs/java.net (CVE-2019-2945, CVE-2019-2978, CVE-2019-2989)

- core-libs/java.lang (CVE-2019-2958)

- client-libs/2d (CVE-2019-2962, CVE-2019-2983, CVE-2019-2987, CVE-2019-2988, CVE-2019-2992)

- core-libs/java.util.regex (CVE-2019-2964)

- xml/jaxp (CVE-2019-2973, CVE-2019-2981)

- core-libs/javax.script (CVE-2019-2975)

- tools/javadoc (CVE-2019-2999)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Amazon Corretto Java 8.232.09.1 or later

Plugin Details

Severity: Medium

ID: 159430

File Name: amazon_corretto_8_232_09_1.nasl

Version: 1.5

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 4/1/2022

Updated: 5/6/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2019-2975

CVSS v3

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2019-2989

Vulnerability Information

CPE: cpe:/a:amazon:corretto

Required KB Items: installed_sw/Java

Exploit Ease: No known exploits are available

Patch Publication Date: 10/15/2019

Vulnerability Publication Date: 10/15/2019

Reference Information

CVE: CVE-2019-2894, CVE-2019-2933, CVE-2019-2945, CVE-2019-2949, CVE-2019-2958, CVE-2019-2962, CVE-2019-2964, CVE-2019-2973, CVE-2019-2975, CVE-2019-2978, CVE-2019-2981, CVE-2019-2983, CVE-2019-2987, CVE-2019-2988, CVE-2019-2989, CVE-2019-2992, CVE-2019-2999

IAVA: 2019-A-0385