Spring Cloud Function SPEL Expression Injection (direct check)

critical Nessus Plugin ID 159375

Synopsis

Spring Cloud Function running on the remote host is affected by a remote code execution vulnerability.

Description

The version of Spring Cloud Function running on the remote host is affected by a remote code execution vulnerability in the routing functionality. A remote, unauthenticated attacker could provide a specially crafted SpEL as a routing expression that may result in remote code execution on the remote host.

Solution

Upgrade to Spring Cloud Function version 3.1.7 or 3.2.3 or later.

See Also

https://tanzu.vmware.com/security/cve-2022-22963

https://nsfocusglobal.com/spring-cloud-function-spel-expression-injection-vulnerability-alert/

https://github.com/hktalent/spring-spel-0day-poc

Plugin Details

Severity: Critical

ID: 159375

File Name: spring_cloud_CVE-2022-22963.nbin

Version: 1.11

Type: remote

Family: CGI abuses

Published: 3/31/2022

Updated: 7/19/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Critical

Score: 9.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2022-22963

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:spring_cloud_function

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/29/2022

Vulnerability Publication Date: 3/28/2022

Exploitable With

Metasploit (Spring Cloud Function SpEL Injection)

Reference Information

CVE: CVE-2022-22963