Sun Java Applet Invocation Version Specification

High Nessus Plugin ID 15926


The remote Windows host contains a runtime environment that is affected by multiple vulnerabilities.


The remote version of Windows contains a version of the Java JRE that is older than 1.4.2_06 / 1.3.1_13.

Even if a newer version of this software is installed, a malicious Java applet may invoke a particular version of the Java JRE to be executed with. As a result, a rogue Java applet could exploit this vulnerability by requesting to be executed with an older, vulnerable version of the JRE.


Uninstall any outdated versions of the JRE.

See Also

Plugin Details

Severity: High

ID: 15926

File Name: java_jre_version_invocation.nasl

Version: $Revision: 1.22 $

Type: local

Agent: windows

Family: Windows

Published: 2004/12/08

Modified: 2013/09/06

Dependencies: 33545

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:jre

Required KB Items: SMB/Java/JRE/Installed

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2006/08/26

Vulnerability Publication Date: 2004/11/25

Reference Information

CVE: CVE-2006-4302

BID: 11757, 11757

OSVDB: 28109