Debian DSA-5107-1 : php-twig - security update

critical Nessus Plugin ID 159202

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 11 host has packages installed that are affected by a vulnerability as referenced in the dsa-5107 advisory.

- Twig is an open source template language for PHP. When in a sandbox mode, the `arrow` parameter of the `sort` filter must be a closure to avoid attackers being able to run arbitrary PHP functions. In affected versions this constraint was not properly enforced and could lead to code injection of arbitrary PHP code.
Patched versions now disallow calling non Closure in the `sort` filter as is the case for some other filters. Users are advised to upgrade. (CVE-2022-23614)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the php-twig packages.

For the stable distribution (bullseye), this problem has been fixed in version 2.14.3-1+deb11u1.

See Also

https://security-tracker.debian.org/tracker/source-package/php-twig

https://www.debian.org/security/2022/dsa-5107

https://security-tracker.debian.org/tracker/CVE-2022-23614

https://packages.debian.org/source/bullseye/php-twig

Plugin Details

Severity: Critical

ID: 159202

File Name: debian_DSA-5107.nasl

Version: 1.2

Type: local

Agent: unix

Published: 3/24/2022

Updated: 3/24/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-23614

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php-twig, p-cpe:/a:debian:debian_linux:php-twig-cssinliner-extra, p-cpe:/a:debian:debian_linux:php-twig-doc, p-cpe:/a:debian:debian_linux:php-twig-extra-bundle, p-cpe:/a:debian:debian_linux:php-twig-html-extra, p-cpe:/a:debian:debian_linux:php-twig-inky-extra, p-cpe:/a:debian:debian_linux:php-twig-intl-extra, p-cpe:/a:debian:debian_linux:php-twig-markdown-extra, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 3/24/2022

Vulnerability Publication Date: 2/4/2022

Reference Information

CVE: CVE-2022-23614