CRI-O package 1.19.x < 1.19.6 / 1.20.x < 1.20.7 / 1.21.x < 1.21.6 / 1.22.x < 1.22.3 / 1.23.x < 1.23.2 Arbitrary Code Execution (CVE-2022-0811)

high Nessus Plugin ID 159113

Synopsis

A package installed on the remote host is affected by arbitrary code execution.

Description

The version of the CRI-O package installed on the remote host is 1.19.x prior to 1.19.6, 1.20.x prior to 1.20.7, 1.21.x prior to 1.21.6, 1.22.x prior to 1.22.3, or 1.23.x prior to 1.23.2. It is, therefore, affected by an arbitrary code execution vulnerability via abusing the 'kernel.core_pattern' kernel parameter.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update to version 1.19.6, 1.20.7, 1.21.6, 1.22.3, 1.23.2 or later.

See Also

https://github.com/cri-o/cri-o/security/advisories/GHSA-6x2m-w449-qwx7

http://www.nessus.org/u?f56a5f3f

Plugin Details

Severity: High

ID: 159113

File Name: cri-o_CVE-2022-0811.nasl

Version: 1.4

Type: local

Agent: unix

Family: Misc.

Published: 3/21/2022

Updated: 7/27/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-0811

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:kubernetes:cri-o

Required KB Items: Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 3/15/2022

Vulnerability Publication Date: 3/15/2022

Reference Information

CVE: CVE-2022-0811