GitLab 8.15.x < 14.6.5 / 14.7.x < 14.7.4 / 14.8.x < 14.8.2 DoS

medium Nessus Plugin ID 158891


A source control application running on the remote web server is affected by a denial of service vulnerability.


According to its self-reported version, the instance of GitLab running on the remote web server is 8.15.x prior to 14.6.5, 14.7.x prior to 14.7.4, or 14.8.x prior to 14.8.2. It is, therefore, affected by a denial of service vulnerability in issue comments. An authenticated, remote attacker can exploit this, by using the math feature with a specific formula in issue comments, to cause GitLab to stop responding.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.6.5, 14.7.4, 14.8.2, or later.

See Also

Plugin Details

Severity: Medium

ID: 158891

File Name: gitlab_cve-2022-0489.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 3/14/2022

Updated: 10/11/2022

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P

CVSS Score Source: CVE-2022-0489


Risk Factor: Medium

Base Score: 5.7

Temporal Score: 5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 2/25/2022

Vulnerability Publication Date: 2/25/2022

Reference Information

CVE: CVE-2022-0489

IAVA: 2022-A-0099-S