Fortinet FortiWeb < 6.3.16 / 6.4.x < 6.4.2 Heap-Based Buffer Overflow (FG-IR-21-160)

high Nessus Plugin ID 158687

Synopsis

The remote host is affected by heap-base buffer overflow vulnerability

Description

The remote host is running a version of FortiWeb prior or equal to 6.3.15 or 6.4.x prior or equal to 6.4.1. It is, therefore, affected by a multiple heap-based buffer overflow vulnerability in web API controllers of FortiWeb. An authenticated, remote attacker can exploit this issue, by sending a specially crafted HTTP requests to execute arbitrary code or commands in the system.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

See vendor advisory.

See Also

https://fortiguard.com/psirt/FG-IR-21-160

Plugin Details

Severity: High

ID: 158687

File Name: fortiweb_FG-IR-21-160.nasl

Version: 1.2

Type: local

Family: CGI abuses

Published: 3/8/2022

Updated: 3/9/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-41017

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:fortinet:fortiweb

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Ease: No known exploits are available

Patch Publication Date: 12/7/2021

Vulnerability Publication Date: 12/7/2021

Reference Information

CVE: CVE-2021-41017

IAVA: 2021-A-0574