IBM WebSphere Application Server 9.x < 9.0.5.12 Clickjacking

medium Nessus Plugin ID 158561

Synopsis

The remote web application server is vulnerable to clickjacking.

Description

The IBM WebSphere Application Server running on the remote host is 9.x prior to 9.0.5.12. It is, therefore, affected by a clickjacking vulnerability. By persuading a victim to visit a malicious Web site, a remote attacker could exploit this vulnerability to hijack the victim's click actions and possibly launch further attacks against the victim.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update to IBM WebSphere Application Server version 9.0.5.12 or later. Alternatively, upgrade to the minimal fix pack levels required by the interim fix and then apply Interim Fix PH43760.

See Also

https://www.ibm.com/support/pages/node/6559044

Plugin Details

Severity: Medium

ID: 158561

File Name: websphere_9_0_5_12.nasl

Version: 1.7

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 3/3/2022

Updated: 6/20/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-39038

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: installed_sw/IBM WebSphere Application Server

Exploit Ease: No known exploits are available

Patch Publication Date: 2/23/2022

Vulnerability Publication Date: 2/23/2022

Reference Information

CVE: CVE-2021-39038

IAVA: 2022-A-0094-S