RHEL 7 : kernel (RHSA-2022:0620)

high Nessus Plugin ID 158266

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2022:0620 advisory.

- kernel: out of bounds write in hid-multitouch.c may lead to escalation of privilege (CVE-2020-0465)

- kernel: use after free in eventpoll.c may lead to escalation of privilege (CVE-2020-0466)

- kernel: Use After Free in unix_gc() which could result in a local privilege escalation (CVE-2021-0920)

- kernel: double free in bluetooth subsystem when the HCI device initialization fails (CVE-2021-3564)

- kernel: use-after-free in function hci_sock_bound_ioctl() (CVE-2021-3573)

- kernel: possible use-after-free in bluetooth module (CVE-2021-3752)

- kernel: xfs: raw block device data leak in XFS_IOC_ALLOCSP IOCTL (CVE-2021-4155)

- kernel: possible privileges escalation due to missing TLB flush (CVE-2022-0330)

- kernel: failing usercopy allows for use-after-free exploitation (CVE-2022-22942)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://access.redhat.com/security/cve/CVE-2020-0465

https://access.redhat.com/security/cve/CVE-2020-0466

https://access.redhat.com/security/cve/CVE-2021-0920

https://access.redhat.com/security/cve/CVE-2021-3564

https://access.redhat.com/security/cve/CVE-2021-3573

https://access.redhat.com/security/cve/CVE-2021-3752

https://access.redhat.com/security/cve/CVE-2021-4155

https://access.redhat.com/security/cve/CVE-2022-0330

https://access.redhat.com/security/cve/CVE-2022-22942

https://access.redhat.com/errata/RHSA-2022:0620

https://bugzilla.redhat.com/1920471

https://bugzilla.redhat.com/1920480

https://bugzilla.redhat.com/1964139

https://bugzilla.redhat.com/1966578

https://bugzilla.redhat.com/1999544

https://bugzilla.redhat.com/2031930

https://bugzilla.redhat.com/2034813

https://bugzilla.redhat.com/2042404

https://bugzilla.redhat.com/2044809

Plugin Details

Severity: High

ID: 158266

File Name: redhat-RHSA-2022-0620.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2/23/2022

Updated: 9/22/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: High

Base Score: 7.9

Temporal Score: 6.9

Vector: AV:A/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2021-3752

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 7.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

CVSS Score Source: CVE-2022-0330

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:bpftool, p-cpe:/a:redhat:enterprise_linux:kernel, p-cpe:/a:redhat:enterprise_linux:kernel-abi-whitelists, p-cpe:/a:redhat:enterprise_linux:kernel-bootwrapper, p-cpe:/a:redhat:enterprise_linux:kernel-debug, p-cpe:/a:redhat:enterprise_linux:kernel-debug-devel, p-cpe:/a:redhat:enterprise_linux:kernel-devel, p-cpe:/a:redhat:enterprise_linux:kernel-headers, p-cpe:/a:redhat:enterprise_linux:kernel-kdump, p-cpe:/a:redhat:enterprise_linux:kernel-kdump-devel, p-cpe:/a:redhat:enterprise_linux:kernel-tools, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs-devel, p-cpe:/a:redhat:enterprise_linux:perf, p-cpe:/a:redhat:enterprise_linux:python-perf

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/22/2022

Vulnerability Publication Date: 12/14/2020

CISA Known Exploited Dates: 6/13/2022

Reference Information

CVE: CVE-2020-0465, CVE-2020-0466, CVE-2021-0920, CVE-2021-3564, CVE-2021-3573, CVE-2021-3752, CVE-2021-4155, CVE-2022-0330, CVE-2022-22942

RHSA: 2022:0620

CWE: 20, 131, 200, 281, 362, 415, 416, 787