PHP 8.1.x < 8.1.3

critical Nessus Plugin ID 158154

Synopsis

The version PHP running on the remote web server is affected by a vulnerability.

Description

The version of PHP installed on the remote host is prior to 8.1.3. It is, therefore, affected by a vulnerability as referenced in the Version 8.1.3 advisory.

- In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.
(CVE-2021-21708)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 8.1.3 or later.

See Also

http://php.net/ChangeLog-8.php#8.1.3

Plugin Details

Severity: Critical

ID: 158154

File Name: php_8_1_3.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2/18/2022

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-21708

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2/17/2022

Vulnerability Publication Date: 2/17/2022

Reference Information

CVE: CVE-2021-21708