RHEL 7 : Red Hat JBoss Web Server 3.1 Service Pack 14 Security Update (Low) (RHSA-2022:0524)

critical Nessus Plugin ID 158057

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2022:0524 advisory.

- log4j: Remote code execution in Log4j 1.x when application is configured to use JMSAppender (CVE-2021-4104)

- log4j: Remote code execution in Log4j 1.x when application is configured to use JMSSink (CVE-2022-23302)

- log4j: SQL injection in Log4j 1.x when application is configured to use JDBCAppender (CVE-2022-23305)

- log4j: Unsafe deserialization flaw in Chainsaw log viewer (CVE-2022-23307)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?b50013b9

https://access.redhat.com/security/updates/classification/#low

https://access.redhat.com/errata/RHSA-2022:0524

https://bugzilla.redhat.com/show_bug.cgi?id=2031667

https://bugzilla.redhat.com/show_bug.cgi?id=2041949

https://bugzilla.redhat.com/show_bug.cgi?id=2041959

https://bugzilla.redhat.com/show_bug.cgi?id=2041967

Plugin Details

Severity: Critical

ID: 158057

File Name: redhat-RHSA-2022-0524.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2/14/2022

Updated: 4/28/2024

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2022-23307

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS Score Source: CVE-2022-23305

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:tomcat7-javadoc, p-cpe:/a:redhat:enterprise_linux:tomcat7-jsp-2.2-api, p-cpe:/a:redhat:enterprise_linux:tomcat7-jsvc, p-cpe:/a:redhat:enterprise_linux:tomcat7-lib, p-cpe:/a:redhat:enterprise_linux:tomcat7-log4j, p-cpe:/a:redhat:enterprise_linux:tomcat7-selinux, p-cpe:/a:redhat:enterprise_linux:tomcat7-servlet-3.0-api, p-cpe:/a:redhat:enterprise_linux:tomcat7-webapps, p-cpe:/a:redhat:enterprise_linux:tomcat8, p-cpe:/a:redhat:enterprise_linux:tomcat8-admin-webapps, p-cpe:/a:redhat:enterprise_linux:tomcat8-docs-webapp, p-cpe:/a:redhat:enterprise_linux:tomcat8-el-2.2-api, p-cpe:/a:redhat:enterprise_linux:tomcat8-javadoc, p-cpe:/a:redhat:enterprise_linux:tomcat8-jsp-2.3-api, p-cpe:/a:redhat:enterprise_linux:tomcat8-jsvc, p-cpe:/a:redhat:enterprise_linux:tomcat8-lib, p-cpe:/a:redhat:enterprise_linux:tomcat8-log4j, p-cpe:/a:redhat:enterprise_linux:tomcat8-selinux, p-cpe:/a:redhat:enterprise_linux:tomcat8-servlet-3.1-api, p-cpe:/a:redhat:enterprise_linux:tomcat8-webapps, cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:log4j-eap6, p-cpe:/a:redhat:enterprise_linux:tomcat-native, p-cpe:/a:redhat:enterprise_linux:tomcat7, p-cpe:/a:redhat:enterprise_linux:tomcat7-admin-webapps, p-cpe:/a:redhat:enterprise_linux:tomcat7-docs-webapp, p-cpe:/a:redhat:enterprise_linux:tomcat7-el-2.2-api

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/14/2022

Vulnerability Publication Date: 12/14/2021

Reference Information

CVE: CVE-2021-4104, CVE-2022-23302, CVE-2022-23305, CVE-2022-23307

CWE: 20, 502, 89

IAVA: 2021-A-0573

RHSA: 2022:0524