Security Updates for Microsoft SharePoint Server 2019 (February 2022)

high Nessus Plugin ID 157852

Synopsis

The Microsoft SharePoint Server 2019 installation on the remote host is affected by multiple vulnerabilities.

Description

The Microsoft SharePoint Server 2019 installation on the remote host is missing security updates. It is, therefore, affected by multiple vulnerabilities:

- A session spoofing vulnerability exists. An attacker can exploit this to perform actions with the privileges of another user. (CVE-2022-21987)

- A remote code execution vulnerability. An attacker can exploit this to bypass authentication and execute unauthorized arbitrary commands. (CVE-2022-22005)

- A security feature bypass vulnerability exists. An attacker can exploit this and bypass the security feature and perform unauthorized actions compromising the integrity of the system/application.
(CVE-2022-21968)

Solution

Microsoft has released KB5002135 to address this issue.

See Also

https://support.microsoft.com/en-us/help/5002135

Plugin Details

Severity: High

ID: 157852

File Name: smb_nt_ms22_feb_office_sharepoint_2019.nasl

Version: 1.5

Type: local

Agent: windows

Published: 2/9/2022

Updated: 4/27/2022

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-22005

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:sharepoint_server

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Ease: No known exploits are available

Patch Publication Date: 2/8/2022

Vulnerability Publication Date: 2/8/2022

Reference Information

CVE: CVE-2022-21968, CVE-2022-21987, CVE-2022-22005

MSKB: 5002135

MSFT: MS22-5002135

IAVA: 2022-A-0065-S