Rocky Linux 8 : aide (RLSA-2022:441)

high Nessus Plugin ID 157844

Synopsis

The remote Rocky Linux host is missing a security update.

Description

The remote Rocky Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RLSA-2022:441 advisory.

- AIDE before 0.17.4 allows local users to obtain root privileges via crafted file metadata (such as XFS extended attributes or tmpfs ACLs), because of a heap-based buffer overflow. (CVE-2021-45417)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected aide, aide-debuginfo and / or aide-debugsource packages.

See Also

https://errata.rockylinux.org/RLSA-2022:441

https://bugzilla.redhat.com/show_bug.cgi?id=2041489

Plugin Details

Severity: High

ID: 157844

File Name: rocky_linux_RLSA-2022-441.nasl

Version: 1.3

Type: local

Published: 2/9/2022

Updated: 2/14/2022

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-45417

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:rocky:linux:aide, p-cpe:/a:rocky:linux:aide-debuginfo, p-cpe:/a:rocky:linux:aide-debugsource, cpe:/o:rocky:linux:8

Required KB Items: Host/local_checks_enabled, Host/RockyLinux/release, Host/RockyLinux/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 2/7/2022

Vulnerability Publication Date: 1/20/2022

Reference Information

CVE: CVE-2021-45417

RLSA: 2022:441