Mandrake Linux Security Advisory : gd (MDKSA-2004:132)

Critical Nessus Plugin ID 15737


The remote Mandrake Linux host is missing one or more security updates.


Integer overflows were reported in the GD Graphics Library (libgd) 2.0.28, and possibly other versions. These overflows allow remote attackers to cause a denial of service and possibly execute arbitrary code via PNG image files with large image rows values that lead to a heap-based buffer overflow in the gdImageCreateFromPngCtx() function.

The updated packages have been patched to prevent these issues.


Update the affected packages.

Plugin Details

Severity: Critical

ID: 15737

File Name: mandrake_MDKSA-2004-132.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/11/17

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gd-utils, p-cpe:/a:mandriva:linux:lib64gd2, p-cpe:/a:mandriva:linux:lib64gd2-devel, p-cpe:/a:mandriva:linux:lib64gd2-static-devel, p-cpe:/a:mandriva:linux:libgd2, p-cpe:/a:mandriva:linux:libgd2-devel, p-cpe:/a:mandriva:linux:libgd2-static-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/11/15

Reference Information

CVE: CVE-2004-0941, CVE-2004-0990

MDKSA: 2004:132