Tenable Nessus 10.x < 10.1.0 / 8.x < 8.15.3 Third-Party Vulnerability (TNS-2022-04)

high Nessus Plugin ID 157339

Synopsis

Tenable Nessus running on the remote host is affected by a third-party vulnerability.

Description

According to its self-reported version, the Tenable Nessus application running on the remote host is 10.x prior to 10.1.0, or 8.x prior to 8.15.3. It is, therefore, affected by a vulnerability in a third-party library:

- The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized. (CVE-2021-23358)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Tenable Nessus version 8.15.3 / 10.1.0 or later.

See Also

https://www.tenable.com/security/tns-2022-04

https://docs.tenable.com/releasenotes/Content/nessus/nessus8153.htm

https://docs.tenable.com/releasenotes/Content/nessus/nessus1010.htm

Plugin Details

Severity: High

ID: 157339

File Name: nessus_tns_2022_04.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 2/3/2022

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-23358

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Ease: No known exploits are available

Patch Publication Date: 2/8/2022

Vulnerability Publication Date: 3/29/2021

Reference Information

CVE: CVE-2021-23358