Apache Tomcat 10.1.0.M1 < 10.1.0.M10 multiple vulnerabilities

high Nessus Plugin ID 157120

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities

Description

The version of Tomcat installed on the remote host is prior to 10.1.0.M10. It is, therefore, affected by a vulnerability as referenced in the fixed_in_apache_tomcat_10.1.0-m10_security-10 advisory.

- The fix for bug CVE-2020-9484 introduced a time of check, time of use vulnerability into Apache Tomcat 10.1.0-M1 to 10.1.0-M8, 10.0.0-M5 to 10.0.14, 9.0.35 to 9.0.56 and 8.5.55 to 8.5.73 that allowed a local attacker to perform actions with the privileges of the user that the Tomcat process is using. This issue is only exploitable when Tomcat is configured to persist sessions using the FileStore. (CVE-2022-23181)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 10.1.0.M10 or later.

See Also

http://www.nessus.org/u?7d6bf2f5

http://www.nessus.org/u?b1a49199

Plugin Details

Severity: High

ID: 157120

File Name: tomcat_10_1_0_M10.nasl

Version: 1.8

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 1/26/2022

Updated: 4/28/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Low

Base Score: 3.7

Temporal Score: 2.7

Vector: AV:L/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-23181

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Ease: No known exploits are available

Patch Publication Date: 1/20/2022

Vulnerability Publication Date: 5/20/2020

Reference Information

CVE: CVE-2022-23181

IAVA: 2020-A-0225-S, 2020-A-0324