Foxit PDF Reader for Mac < 11.1.1 Multiple Vulnerabilities

high Nessus Plugin ID 157115

Synopsis

A PDF viewer installed on the remote macOS host is affected by multiple vulnerabilities

Description

According to its version, the Foxit PDF Reader for Mac application (previously named Foxit Reader for Mac) installed on the remote macOS host is prior to 11.1.1. It is, therefore affected by multiple vulnerabilities:

- An out-of-bounds read error exists in Foxit PDF Reader for Mac due to the application failing to validate the object properly while handling the width attribute of certain XFA widget. An unauthenticated, local attacker can exploit this to cause an information disclosure and crash. (CVE-2022-24370)

- An out-of-bounds read error exists in Foxit PDF Reader for Mac due to the application failing to delete the page object in a timely manner after a page has been deleted. An unauthenticated, local attacker can exploit this to execute arbitrary code. (CVE-2022-24356)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Foxit PDF Reader for Mac version 11.1.1 or later

See Also

http://www.nessus.org/u?a27a3e57

Plugin Details

Severity: High

ID: 157115

File Name: macos_foxit_reader_11_1_1.nasl

Version: 1.7

Type: local

Agent: macosx

Published: 1/26/2022

Updated: 8/16/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-24356

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:foxit_reader

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Foxit Reader

Exploit Ease: No known exploits are available

Patch Publication Date: 1/25/2022

Vulnerability Publication Date: 1/25/2022

Reference Information

CVE: CVE-2022-24356, CVE-2022-24370

IAVA: 2022-A-0091-S