Debian DLA-2897-1 : apr - LTS security update

high Nessus Plugin ID 157058

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has packages installed that are affected by a vulnerability as referenced in the dla-2897 advisory.

- When apr_time_exp*() or apr_os_exp_time*() functions are invoked with an invalid month field value in Apache Portable Runtime APR 1.6.2 and prior, out of bounds memory may be accessed in converting this value to an apr_time_exp_t value, potentially revealing the contents of a different static heap value or resulting in program termination, and may represent an information disclosure or denial of service vulnerability to applications which call these APR functions with unvalidated external input.
(CVE-2017-12613)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the apr packages.

For Debian 9 stretch, this problem has been fixed in version 1.5.2-5+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/apr

https://www.debian.org/lts/security/2022/dla-2897

https://security-tracker.debian.org/tracker/CVE-2017-12613

https://packages.debian.org/source/stretch/apr

Plugin Details

Severity: High

ID: 157058

File Name: debian_DLA-2897.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/25/2022

Updated: 1/25/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2017-12613

VPR

Risk Factor: High

Score: 7.7

CVSS v2

Risk Factor: Low

Base Score: 3.6

Temporal Score: 2.7

Vector: AV:L/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libapr1, p-cpe:/a:debian:debian_linux:libapr1-dbg, p-cpe:/a:debian:debian_linux:libapr1-dev, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/24/2022

Vulnerability Publication Date: 10/23/2017

Reference Information

CVE: CVE-2017-12613