Debian DLA-2894-1 : aide - LTS security update

high Nessus Plugin ID 157055

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has a package installed that is affected by a vulnerability as referenced in the dla-2894 advisory.

- AIDE before 0.17.4 allows local users to obtain root privileges via crafted file metadata (such as XFS extended attributes or tmpfs ACLs), because of a heap-based buffer overflow. (CVE-2021-45417)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the aide packages.

For Debian 9 stretch, this problem has been fixed in version 0.16-1+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/aide

https://www.debian.org/lts/security/2022/dla-2894

https://security-tracker.debian.org/tracker/CVE-2021-45417

https://packages.debian.org/source/stretch/aide

Plugin Details

Severity: High

ID: 157055

File Name: debian_DLA-2894.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/25/2022

Updated: 1/25/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-45417

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:aide-common, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/25/2022

Vulnerability Publication Date: 1/20/2022

Reference Information

CVE: CVE-2021-45417